Changes between Version 1 and Version 2 of coding_rules


Ignore:
Timestamp:
08/09/10 15:13:13 (15 years ago)
Author:
Mathieu Morlighem
Comment:

added comments

Legend:

Unmodified
Added
Removed
Modified
  • coding_rules

    v1 v2  
    11
    2 == Coding rules ==
     2== Variable Names ==
    33
    44 - variables should not use capital letters. Use underscores to make variables more understandable.
     5
     6== Enum Names ==
     7
    58 - Function names and enums should not use any underscore. Use capital letters to make names more understandable.
    69Example:
     
    912  Input* vx_input=GetInput(inputs,VxInput);
    1013}}}
     14
     15== Function/Modules Names ==
     16
     17Functions that return an output corresponding to a given input should be named as follows:
     18   - EnumToString
     19   - IdToName
     20Never ever Id2Name or IdAsName,...
     21If necessary, "From" can be used instead of "To" if emphasis has to be put on the input:
     22   - ResultFromInputs